Major bump in web-server performance!

zagman76

Wackbagger, Geek, Administrator
Wackbag Staff
Joined
Nov 18, 2004
Messages
12,593
Likes
589
Points
628
Location
Long Island, NY
#1
I'd like to announce that for this weekend, and likely a good part of next week, I have re-built the entire website behind a load balancer. What this means, is that many more people can visit the site, and performance shouldn't be an issue. It should remain fast, and "up" for all.

To access the newly built site, please visit:
https://www.wackbag.com OR http://www.wackbag.com

Thank you to those who were helping me test the additional web servers, and a huge thank you to all who donated this month. Without that giant surge, I would not have been able to get all of this set up and working properly, so again: Thank you!!

Please feel free to HAMMER the site with posts and such to give it a good workout!
 

Hudson

Supreme Champion!!!!!
Donator
Joined
Jan 14, 2002
Messages
32,840
Likes
4,566
Points
898
Location
Land of misfit toys
#8
what's with the partially obscured sub menus at the top of the page?
 

Ballbuster1

In The Danger Zone...
Wackbag Staff
Joined
Aug 26, 2002
Messages
102,377
Likes
16,437
Points
839
Location
Your house, behind the couch
#10
Yeah, I'm getting them and that notification problem too.

Seems to be holding up better in the post whoring thread.

It would have dogged out the way it was earlier in the week.
 

Lord Zero

Viciously Silly
Joined
Aug 25, 2008
Messages
54,116
Likes
12,910
Points
373
Location
Atlanta, GA
#13
@zagman76, @zag_mobile

The board keeps making me log in almost every time I try to post something, "like" someone else's post, open something in another tab, or check an alert.
 
Last edited:

Lord Zero

Viciously Silly
Joined
Aug 25, 2008
Messages
54,116
Likes
12,910
Points
373
Location
Atlanta, GA
#17
Have you cleared the Wackbag cookie?
I use incognito browsing exclusively and my browser auto-deletes my history whenever I close it, so I don't know if I even get the cookie, for all intents and purposes.
 

zagman76

Wackbagger, Geek, Administrator
Wackbag Staff
Joined
Nov 18, 2004
Messages
12,593
Likes
589
Points
628
Location
Long Island, NY
#18
I use incognito browsing exclusively and my browser auto-deletes my history whenever I close it, so I don't know if I even get the cookie, for all intents and purposes.
You get it, but it's deleted when all incognito windows are closed (if using Chrome).
 

zagman76

Wackbagger, Geek, Administrator
Wackbag Staff
Joined
Nov 18, 2004
Messages
12,593
Likes
589
Points
628
Location
Long Island, NY
#21
"Private browsing" may have an effect on that. If a Cookie can't be set, then your logged in status likely won't be remembered. With the web server being load-balanced now, one click may take you to one server, and a second click may take you to another server. Can you try it in another browser (like Chrome and "Incognito" mode)?
 

Lord Zero

Viciously Silly
Joined
Aug 25, 2008
Messages
54,116
Likes
12,910
Points
373
Location
Atlanta, GA
#22
"Private browsing" may have an effect on that. If a Cookie can't be set, then your logged in status likely won't be remembered. With the web server being load-balanced now, one click may take you to one server, and a second click may take you to another server. Can you try it in another browser (like Chrome and "Incognito" mode)?
I'll try it tomorrow. /lazy
 

zagman76

Wackbagger, Geek, Administrator
Wackbag Staff
Joined
Nov 18, 2004
Messages
12,593
Likes
589
Points
628
Location
Long Island, NY
#25
The sysadmin in me need to know:

Hardware LB? Software? What's your server farm behind it?
Amazon AWS:
ELB + EC2 + EBS + Route53
 
Top Bottom