Windows boot menu

Sinn Fein

Infidel and White Interloper
Wackbag Staff
Aug 29, 2002
31,547
2,205
898
Florida's Nature Coast
#1
This is annoying the shit out of me. I've tried Googling for the answer and haven't come up with anything.

Our home desktop PC had XP home on it. I've upgraded it to XP Pro SP2 a while back. Since then, at boot I get two options:

Microsoft Windows XP Professional
Microsoft Windows (default)

System defaults to the 2nd choice and doesn't boot. So, I can't do an unattended reboot. Whenever I reboot, I gotta be there to hit the up arrow and then hit enter to make the proper choice so it will boot. How the fuck do I change the default and/or simply remove the 2nd option?

This has been driving me nuts.
 

crippledalbino

The God of 42nd Street
Donator
Aug 16, 2006
40,615
11,960
628
The Oh-See, Fuck-Asses
#2
I'd love to know the answer too, because I'm in a situation where it's trying to load into a setup program, but there's a DLL that's not working right, and what it's done is completely shut down the whole computer, because Windows won't load, won't setup properly, and won't... well, anyhow, no one cares, but I'm having the same problem.

In Sympathy, I post.
 
R

rjm_27

Guest
#3
This should be an easy one. LOL! Do the following Right click My Computer -> Properties -> Advanced, under Startup and Recovery select Settings. There should be an option with a pulldown for Default Operating System. From there you should be able to select which OS you want to set as the default during boot up.

Hopefully this helps!
 

Sinn Fein

Infidel and White Interloper
Wackbag Staff
Aug 29, 2002
31,547
2,205
898
Florida's Nature Coast
#5
No dice. It was only showing one choice on the drop-down menu, and that choice was Microsoft Windows XP Professional. I clicked on the button to manually edit the bootup file and found that it was showing the default OS being on partition #2 of the hard drive (there is no partition 2). So I deleted the info for the default option and did a cut-paste of the Windows XP Professional info which was listed under [operating systems] (only thing listed). I did a reboot, and it's still doing the same motherfucking damn thing.
 

Party Rooster

Unleash The Beast
Apr 27, 2005
40,284
7,454
438
The Inland Empire State
#9
I'd love to know the answer too, because I'm in a situation where it's trying to load into a setup program, but there's a DLL that's not working right, and what it's done is completely shut down the whole computer, because Windows won't load, won't setup properly, and won't... well, anyhow, no one cares, but I'm having the same problem.

In Sympathy, I post.
You're not getting a "NTDLR is missing" or cannot find NTLDR.dll error message are you? That's usually big trouble. Could be your master boot record or bad hardrive issues.
 
Apr 14, 2003
4,056
0
0
Eastern MD
#10
Something that may be doing this is that you have a second hardware profile set up for some reason. Right click on My Computer -> Properties -> Hardware tab, then click the "hardware profiles" button. If there are two there, then that's why you get the choice at boot up. You can remove the problem one (or modify the settings so it doesn't automatically choose the bad one). Just a guess as to what the problem might be.
 

Party Rooster

Unleash The Beast
Apr 27, 2005
40,284
7,454
438
The Inland Empire State
#11
This is annoying the shit out of me. I've tried Googling for the answer and haven't come up with anything.

Our home desktop PC had XP home on it. I've upgraded it to XP Pro SP2 a while back. Since then, at boot I get two options:

Microsoft Windows XP Professional
Microsoft Windows (default)

System defaults to the 2nd choice and doesn't boot. So, I can't do an unattended reboot. Whenever I reboot, I gotta be there to hit the up arrow and then hit enter to make the proper choice so it will boot. How the fuck do I change the default and/or simply remove the 2nd option?

This has been driving me nuts.
Click on Start>Run>Type msconfig>Click on the boot.ini tab and click on "Check all boot paths." If you get an error message about one being invalid, click "Fix..."

BTW, I'm sure you've backed up your important stuff. :huh:
Messing around with the boot.ini or other things can screw things up.
 

Hey_Asshole

Man, Beer, Wild
Feb 21, 2007
3,482
0
0
TRueWDT
#12
Same thing happened to me....your system thinks it is set up for a dual boot operating system. There is a setting you can change so that it will boot to SP2 without it asking. Click Start > Run >
type msconfig
Click Boot.ini tab
then follow instructions here:http://support.microsoft.com/default.aspx?scid=kb;en-us;Q289022

Sorry I cannot give you a more exact answer because I cant remember exactly what i changed, but the solution to your problem should be able to be corrected with the settings under the Boot.INI tab.

Good Luck.
 

Don the Radio Guy

G-Bb-A-D
Donator
Mar 30, 2006
69,623
5,081
568
Wyoming
#13
Anytime I install windows on a machine now I format the drive to avoid this same thing. It's happened to me more than once. It's a pain in the ass to reinstall all the software but you know you're getting everything back to new as well. If nothing else works you may wanna try that.
 

jsc315

AnalCunt
Dec 8, 2004
2,022
50
313
Evergreen Park,IL
#14
Anytime I install windows on a machine now I format the drive to avoid this same thing. It's happened to me more than once. It's a pain in the ass to reinstall all the software but you know you're getting everything back to new as well. If nothing else works you may wanna try that.
Yea i had this problem a few months ago and i just decided to format the damn drive. Took me a whole weekend to reinstall everything, and there are about 90 or so window updates that is a pain in the ass. I cant wait for SP3 then i wont have to deal with rebooting my PC 5 or 6 times just installing updates when i reinstall windows on someones computer.
You could always go into the registry and mess around and try and fix it that way, but if you don't know what your doing then i highly wouldn't recommend that at all.
I hate to say this because so many so many PC customer service reps. will tell you to format and reinstall windows. If there is not simple way of fixing it and you dont want to pay someone to fix it, its just about one of the few easiest options that will 99% of the time fix your problem.
 

Sinn Fein

Infidel and White Interloper
Wackbag Staff
Aug 29, 2002
31,547
2,205
898
Florida's Nature Coast
#15
I forgot to update...

The issue is resolved. I went into MSCONFIG, then clicked the boot.ini tab. Everything looked ok. It only showed one version of Windows. I clicked "set as default" and that fixed the problem.